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"Connect refused" occurs when connecting with the Salesforce/Oracle Service Cloud driver.

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Title"Connect refused" occurs when connecting with the Salesforce/Oracle Service Cloud driver.
URL Name000040296
Article Number000163006
EnvironmentProduct : Connect for ODBC
Version : All supported versions
Database : Salesforce, Oracle Service Cloud
OS : All supported platforms
Application : All supported applications
Question/Problem Description
The below error occurs when connecting to Salesforce/Oracle Service Cloud.
Connect option "SQL Engine Mode = Server" is used.
Steps to Reproduce
Clarifying Information
Error MessageConnection refused. Verify Host Name and Port Number. Verify that the SQL Engine Service is running.
Defect Number
Enhancement Number
Cause
The error can occur if:
SQL Engine Service is not started
There are errors that cause the SQL Engine Service not to start
Product was not installed using Runas Administrator
There are carriage returns in the JVM Argument text box
The Java installation is corrupted
The text field for Proxy Host is prefixed by a space
Resolution
1. Start the SQL engine JVM:

- Open the Data Source and select the "SQL Engine" tab.
- Select "Edit Server Settings"
- Next to "Services" select "Start"  (If Start is selected, select Stop, then select Start to get confirmation the service is running)

2. Check the following if the service cannot be started, or if the service starts, but the connection error still occurs:

- Go to Start and type "services.msc"
- In the "Services" screen, go to "Progress DataDirect Salesforce SQL Engine" or "Progress DataDirect Oracle Service Cloud SQL Engine"
- Right click mouse and go to Properties
- Check the command that is seen under "Path to executable"
- Start the service
- Go to Start and type "event viewer"
- Check the event log for errors. The Salesforce/OSC service will write out the string that it uses to invoke the java component. To troubleshoot the error, grab that string from the event log and try to execute it on the command line. 

3. Check whether the Java installation is corrupt by executing this command on the command line: java -version

4. Check if the issue still occurs when specifying "1-ForceNew" as "Create Database" option value under the "Advanced" tab of the DSN (Set it to the default value again afterwards).

5. If the server mode has been properly configured and the problem still persists, be sure that the driver software has been installed as administrator.

6. Check to ensure there are no carriage returns in the JVM Arguments. This carriage return is caused by copying and pasting JVM Arguments into the text box.

7. Check to ensure Poxy Host or Proxy Port is not prefixed by a space.
Workaround
Notes
Troubleshooting tip. 
 Set the connection parameter "SQL Engine Mode = Direct" and attempt a test connection. If the connection is successful the problem is related to the SQL engine JVM.
Last Modified Date7/24/2020 7:07 PM
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