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SQL Server Linked Server hangs while using the DataDirect ODBC driver

Information

 
TitleSQL Server Linked Server hangs while using the DataDirect ODBC driver
URL Name000056314
Article Number000142305
EnvironmentProduct: Connect/Connect64 for ODBC, Progress DataDirect for ODBC
Version: All supported versions
OS: Windows
Database: All supported databases
Application: SQL Server Linked Server
Question/Problem Description
SQL Server Linked Server hangs while using the DataDirect ODBC driver due to expired license
Steps to Reproduce
Clarifying Information
Connecting to Salesforce through SQL Server Linked Server, the connection hangs. No error message is displayed.
Executing a query using the DataDirect OpenEdge ODBC driver from SQL Server Linked Server hangs.
Error Message
Defect Number
Enhancement Number
Cause
When troubleshooting issues which occur through SQL Server Linked Server, it is always ideal to bypass Linked Server and connect directly to the database and execute a query. Connect directly to Salesforce using the ODBCTest tool or example sample application.

In this case the driver was installed with an evaluation license and that license had expired. The expired licensed message is not 
propagated back to the end user through SQL Server Linked Server. Using ODBCTest or example the error message was displayed to the end user.
Resolution
Re-install the driver with a valid license or upgrade the license with a valid license to resolve this issue.
Workaround
Notes
Last Modified Date11/20/2020 7:03 AM
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