Feedback
Did this article resolve your question/issue?

   

Article

INVALID_LOGIN error to Salesforce running example program

Information

 
TitleINVALID_LOGIN error to Salesforce running example program
URL NameINVALIDLOGINerrortoSalesforcerunningexampleprogramfromLinux
Article Number000142696
EnvironmentProduct : Connect for ODBC salesforce driver
Version : all supported versions
OS : Linux, AIX, Solaris, HP UX
Database : Salesforce
Application: example application
Question/Problem Description
The error below is returned when connecting to Salesforce using the example program. The same login works from Windows using the ODBC Administrator.  The password requires a security token.
Steps to Reproduce
Clarifying Information
Screenshot of error where security token is: 5odUZUcU2LIWwUS2hAplZlPX:

./example DataDirect Technologies, Inc. ODBC Example Application.
 
Enter the data source name : Salesforce
 
Enter the user name        : sumit.sandbox@progress.com
 
Enter the password         : myPassword5odUZUcU2LIWwUS2hAplZlPX
SQLSTATE = 28000
NATIVE ERROR = 10002
MSG = [DataDirect][ODBC Salesforce driver][Salesforce]INVALID_LOGIN: Invalid username, password, security token; or user locked out.
 
Error Message[DataDirect][ODBC Salesforce driver][Salesforce]INVALID_LOGIN: Invalid username, password, security token; or user locked out.
Defect Number
Enhancement Number
Cause

The example program's password buffer is set to max of 32 characters. The password entered above is 34 characters, which caused the error.

Resolution
Configure the security token in the Salesforce data source in the odbc.ini file with the following property:
SecurityToken=5odUZUcU2LIWwUS2hAplZlPX

Then test connect as follows:
 
./example DataDirect Technologies, Inc. ODBC Example Application.
 
Enter the data source name : Salesforce
 
Enter the user name        : sumit.sandbox2@progress.com
 
Enter the password         : myPassword
 
Enter SQL statements (Press ENTER to QUIT)
SQL>

If this still does not work, check if the user name is written on one line and not as:

sumit.sandbox2@
progress.com


If this is the case, you need to check the profile whether the "@" key does not force the cursor to jump to a new line: run "stty -a".
Check the following document where "@" key issue is discussed: https://www.unix.com/hp-ux/134072-typing-sign-creates-new-line.html
Workaround
Notes
Last Modified Date11/25/2019 8:29 PM
Files
Disclaimer The origins of the information on this site may be internal or external to Progress Software Corporation (“Progress”). Progress Software Corporation makes all reasonable efforts to verify this information. However, the information provided is for your information only. Progress Software Corporation makes no explicit or implied claims to the validity of this information.

Any sample code provided on this site is not supported under any Progress support program or service. The sample code is provided on an "AS IS" basis. Progress makes no warranties, express or implied, and disclaims all implied warranties including, without limitation, the implied warranties of merchantability or of fitness for a particular purpose. The entire risk arising out of the use or performance of the sample code is borne by the user. In no event shall Progress, its employees, or anyone else involved in the creation, production, or delivery of the code be liable for any damages whatsoever (including, without limitation, damages for loss of business profits, business interruption, loss of business information, or other pecuniary loss) arising out of the use of or inability to use the sample code, even if Progress has been advised of the possibility of such damages.