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"InvocationTargetException : ZeroGu6: Windows DLL failed to load" error when running DataDirect Connect for ODBC installer 7.1.5 on Windows 2012 R2

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Title"InvocationTargetException : ZeroGu6: Windows DLL failed to load" error when running DataDirect Connect for ODBC installer 7.1.5 on Windows 2012 R2
URL NameInvocationTargetException-ZeroGu6-Windows-DLL-failed-to-load-error-when-running-DataDirect-Connect-for-ODBC-installer-7-1-5-on-Windows-2012-R2
Article Number000176230
EnvironmentProduct: Connect/Connect64 for ODBC driver
Version: 7.1.5
OS: Windows Server 2012 R2, Windows 10
Database: All supported databases
Application: Installer
Question/Problem Description
When running the 7.1.5 installer setup.exe , the application quits unexpectedly with Invocation taget exception
The installation starts, but never makes it to the point of entering any information.

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Steps to Reproduce
Clarifying Information
Error MessageThis Application has Unexpectedly Quit
Invocation of this Java application has cause an Invocation Target Exception. this application will now exit (LAX)
ZeroGu6: Windows DLL failed to load
at ZeroGa4.b(DashoA10*..)
at ZeroGa4.b(DashoA10*..)
at com.zerog.ia.installer.LifeCycleManager.b(DashoA10*..)
at com.zerog.ia.installer.LifeCycleManager.a(DashoA10*..)
at com.zerog.ia.installer.Main.main(DashoA10*..)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:606)
at com.zerog.lax.LAX.launch(DashoA10*..)
at com.zerog.lax.LAX.main(DashoA10*..)
Defect NumberDefect 16167/PSC00340124
Enhancement Number
Cause
The exact cause is not known at this time.
Resolution
Until the fix is available, use the workaround below.
Workaround
Make sure to run the installer using Runas Administrator
Set the installer to run in "Windows 7 Compatibility mode"
a] Right click on setup.exe
b] Go to Troubleshoot Compatibility--> Try recommended Settings--> Test the Program 

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c] The installer will now continue with the setup, prompt the user for information and complete the installation.

If the workaround does not resolve the issue, contact Support to investigate the issue further.
 
Notes
References to other documentation:
Progress Article(s):
How to contact Progress DataDirect Technical support
 
Last Modified Date11/20/2020 7:07 AM
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