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ODBC or JDBC Salesforce error "Destination URL not reset"

Information

 
TitleODBC or JDBC Salesforce error "Destination URL not reset"
URL NameSalesforce-error-Destination-URL-not-reset
Article Number000176348
EnvironmentProduct: Connect/Connect64 XE for ODBC Salesforce driver, Progress DataDirect for ODBC for Salesforce
Version: 7.1, 8.0
Product: ConnectXE for JDBC Salesforce driver, Progress DataDirect for JDBC for Salesforce
Version 5.1, 6.0
OS: All supported
Question/Problem Description
1) After working fine for years, running a query returns the error below.
Test connection is successful.

2) Salesforce problems with less active scenario.
Steps to Reproduce
Clarifying Information
User is using the Salesforce driver as a destination of a replication product and are encountering a problem on their QA system, but not their Prod system. The below error is observed in the test environment on a daily basis and, despite having tried a number of different configurations, it is still a regular occurrence. The user's suspicion is that they are not seeing this issue in production because they are sending more data, more frequently and therefore it never has to sever the authorized connection it has with Salesforce and therefore never has to attempt to ‘Reset the Destination URL’. The fix is a stop of the application service for about 5 min and then a restart but it does cause some issues with data integrity, testing of triggers, determining the timing of record creation, etc.
Error Message[DataDirect][SFORCE JDBC driver][SFORCE] Destination URL not reset. The URL returned from login must be set in the SforceService in statement

[DataDirect][ODBC Salesforce driver][Salesforce]UNKNOWN_EXCEPTION Destination URL not reset. The URL returned from login must be set in the SforceService.
Defect Number
Enhancement Number
Cause
It appears that the application held onto the existing connection after the network was rerouted.
Resolution
Restart the Progress DataDirect Salesforce SQL Engine service or the application to clear any cached connections.
Restarting the application may also be necessary.
To ensure that the issue does not occur again, consider updating the Saleforce Session Timeout setting for the organization or the user.
 
Workaround
Notes
References to other documentation:
Salesforce Knowledge Article: Session timeout issues
https://help.salesforce.com/articleView?id=000317746&type=1&mode=1
Salesforce Help : Docs : Set Up and Maintain Your Salesforce Organization
https://help.salesforce.com/articleView?id=sf.security_overview_sessions.htm&type=5
Last Modified Date5/10/2021 8:54 PM
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