Feedback
Did this article resolve your question/issue?

   

Article

Invalid Query issued by Oracle JDBC driver v5.1 causing Oracle Log pollution

Information

 
TitleInvalid Query issued by Oracle JDBC driver v5.1 causing Oracle Log pollution
URL Nameinvalid-query-issued-by-oracle-jdbc-driver-v5-1-causing-oracle-log-pollution
Article Number000171463
EnvironmentProduct: Connect for JDBC Oracle Driver
Version : 5.1.4.000466
OS: JAVA
Database : Oracle 12.1.0.2
Application: All supported applications
Question/Problem Description

Each time a connection to Oracle database is made using DataDirect Oracle JDBC driver, it was observed that , the driver is executing the following query:
SELECT SYS_CONTEXT ("USERENV", "CLOUD_SERVICE") FROM DUAL;  which results in the ORA-02003 error.

But this execution of the query and the resulting error does not show up in the Spy log.
But it shows up in the Oracle log file on the database side.
One client application makes around 600,000 new connections to the Oracle database per day.
And the Oracle log file gets filled with 600,000 ORA_02003 errors per day causing a huge logging overhead.
It does not break anything in the client application workflow. 

Is there anyway to stop this invalid query being executed by the driver each time you try to connect to the database?

Steps to Reproduce
Clarifying Information
Error MessageORA-02003: invalid USERENV parameter
Defect NumberEnhancement
Enhancement Number
Cause
The driver uses this query to determine if the Oracle server to which it's connected is an ADW/ADWC (autonomous data warehouse) server.
This query is a part of its connection establishment process. Based on the result of this query, the driver makes some internal adjustments which
have an effect on a few pieces of DatabaseMetaData and the way in which transaction isolation levels are changed by the driver. 
Resolution
It was determined that the Progress Product is functioning as designed.

An enhancement to the product can be requested through the Progress Community via an Ideas submission. Customer feedback is valuable and Idea submissions are monitored by our Product Management team. Enhancement requests are reviewed during the planning phase of each new product release and a list of the enhancements chosen for implementation can be found in the Release Notes documents that accompany each release. Once an Idea is submitted the Progress Software Community will have the opportunity to comment on and vote for the Idea.

For detailed information on how to submit an Idea, please refer to Knowledge Base article  How to submit an enhancement request for a Progress product?
Workaround
Notes
Last Modified Date11/20/2020 6:55 AM
Files
Disclaimer The origins of the information on this site may be internal or external to Progress Software Corporation (“Progress”). Progress Software Corporation makes all reasonable efforts to verify this information. However, the information provided is for your information only. Progress Software Corporation makes no explicit or implied claims to the validity of this information.

Any sample code provided on this site is not supported under any Progress support program or service. The sample code is provided on an "AS IS" basis. Progress makes no warranties, express or implied, and disclaims all implied warranties including, without limitation, the implied warranties of merchantability or of fitness for a particular purpose. The entire risk arising out of the use or performance of the sample code is borne by the user. In no event shall Progress, its employees, or anyone else involved in the creation, production, or delivery of the code be liable for any damages whatsoever (including, without limitation, damages for loss of business profits, business interruption, loss of business information, or other pecuniary loss) arising out of the use of or inability to use the sample code, even if Progress has been advised of the possibility of such damages.