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Unable to read to excel DB on remote drive when SequeLink ODBC Client is on UNIX/Linux

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TitleUnable to read to excel DB on remote drive when SequeLink ODBC Client is on UNIX/Linux
URL Nameunable-to-read-to-excel-db-on-remote-drive-when-sequelink-odbc-client-is-on-unix-linux
Article Number000182198
EnvironmentProduct: SequeLink ODBC Socket
Version: 6.0
OS: Windows
ODBC Client OS: UNIX/Linux
Database: MS Access, MS Excel
Application: All supported applications
Question/Problem Description
With SequeLink Socket Server on Windows, and SequeLink ODBC Client is on UNIX/Linux, an Excel file on a remote file system cannot be read.

 
Steps to Reproduce
Clarifying Information
Error Message[DataDirect][ODBC SequeLink driver][ODBC Socket][Microsoft][ODBC Microsoft Access Driver] The Microsoft Access database engine cannot open or write to the file '(unknown)'. It is already opened exclusively by another user, or you need permission to view and write its data.
Defect NumberEnhancement
Enhancement Number
Cause
The Socket Server uses the Client security context, which does not have access to the remote file.
At the current time, there is not a way to configure the server to use the server's security context.
Resolution
It was determined that the Progress Product is functioning as designed.
 
An enhancement to the product can be requested through the Progress Community via an Ideas submission.  Customer feedback is valuable and Idea submissions are monitored by our Product Management team.  Enhancement requests are reviewed during the planning phase of each new product release and a list of the enhancements chosen for implementation can be found in the Release Notes documents that accompany each release.  Once an Idea is submitted the Progress Software Community will have the opportunity to comment on and vote for the Idea.
 
For detailed information on how to submit an Idea, please refer to Knowledge Base article  How to submit an idea for a Progress product enhancement
Workaround
Open the SequeLink Management Console and navigate to SLSocket60
Under SLSocket60, open Configuration/Service Settings/User Security
In User Security, delete existing ServiceAuthMethods and ServiceUser settings
Add new settings ServiceAuthMethods=Anonymous and ServiceUser=Everyone

Under SLSocket60, open Configuration/Data Source Settings/<data source name>
In User Security, delete existing DataSourceLogonMethod settings
Add new setting DataSourceLogonMethod=Anonymous

Save the configuration

In the system Services, right-click on SLSocket60 and choose Properties
On the Log On tab, set "This account" to the user that has access to the remote Excel file
Restart the SLSocket60 service
Notes
Last Modified Date11/20/2020 7:13 AM
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